PSD Logistics Disaster Recovery Guide

Last Updated 20/12/2022

This guide outlines the procedure for recovering PSD Logistics in the event of a catastrophic
failure. This guide is general in nature and cannot anticipate every failure scenario.

The main catastrophic failure scenarios are:
1) Total server failure
2) Hard disk failure
3) Memory failure.
4) Network failure.
5) Access Control System failure.

If PSD Logistics is running on a backed up Virtual Server, the simplest solution might be to
restore the entire VS backup.

PSD Logistics can be easily recovered if a recent full valid database backup is available. In
this scenario, follow the steps outlined in the PSD Logistics Server Transfer document.

If a recent full valid database backup is not available, one might be able to be created from a
recent PSD Logistics snapshot. If one is available, follow the steps outlined in the How To
Restore A PSD Logistics Snapshot document.

If a recent full valid database backup is not available, a full PSD Logistics install and
configuration will need to be performed.

Moving the PSD Logistics Server onto a new server involves 5 main stages.
1) Installing all necessary third party interfaces.
2) Creating a backup file in the current version.
3) Installing the current version on the new server.
4) Restoring the backup file onto the new server.
5) Updating any hostnames or IP addresses if required.

Before you begin.

Step Action

1 Copy the PSD Logistics installation file onto the new server. PSD recommends
creating a C:\PSDLogisticsInstalls\ folder on the new server. Check to see if this
folder exists on the old server, as the installation file on the old server may be
located there and can therefore simply be copied across.

2 Install and configure all required Access Management Software interfaces and
software required for PSD Logistics. A number of interfaces will need to be installed
depending upon your access control system. These interfaces will need to be
installed, configured and verified by your licenced security integrator. PSD is unable
to assist with these interfaces as they are provided by the access control company
and not PSD. PSD Logistics is compatible with the following access control systems:
1) Gallagher/Cardax.

Install and configure the Gallagher OPC Bridge if required.

Install and configure the Gallagher FT Import Export Service if required.

Run the Gallagher Read Only utility to create an account for SQL Server if

required.

Install and configure the Gallagher RESTCardholders web service if

required.

Install and configure the Gallagher RESTEvents web service if required.




PSD Logistics Disaster Recovery Guide

2) Lenel OnGuard
Install and configure the Lenel OnGuard Open Access subscription API if
required.

3) PSD AcceptNet.
Install and configure PSD AcceptNet to run on the same server first.

Do not attempt to install PSD Logistics on the new server until all required interfaces
have been verified as being installed and configured correctly.

3 Configure and MS Windows permissions. This will include, but not be limited to:
1) Configuring any Anti Virus software to exclude the entire PSDLogistics folder
and subfolders from any scanning.
2) Configuring any Firewalls from blocking any of the required ports or
interfaces from being used.
4 Install and configure Google Chrome.
5 Install and configure any required software to enable SMTP (e-mail) access for PSD
Logistics if required.
6 Install and configure any required software to enable SNMP access for PSD

Logistics if required.

Stage 2 : Creating a backup on the current server.

Step Action
1 Log into the Server on which the PSD Logistics Services are installed. You must be
logged into MS Windows as a MS Windows Administrator.
If you are unsure of the server name, run a PSD Logistics Client, but do NOT log in.
The login details window will be displayed.
Enter your Login details.
Login Hame
Pazzword
ak | | Cancel | | Server
2 Click the server button and the PSD Logistics Server’s hostname or IP address will

be displayed.




Connecting To The Server

Server Detailz
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Server Not Found

Server Port

Primary Server \kSecondar}l Server

Server

® HostName  |PSD-NEILAPCA

|| Lacal Hast | | Pitg |

O IP Address | | | | |

Ports

250 7
Database Port 12007 5

Run PSDLogisticsManager.exe using “Run As Administrator”.
This application is located in the C:\Program Files (x86)\PSDLogistics\Manager\
folder by default.

B PSD Logistics Manager 14.10.7

File Help

P5D Logistice Manager

Services \I\ Client \k Review \k Test

PSD Logistics Services

DDEDDEEEDE 1A

EE@

I PSD Logistics Server

[F P50 Logistics Cloud Server
I PSD Logistics Web Server
I PSD Logistics Weh Services
IF P50 Logistics Reporting

I PSD Logistics Archive Reporting

I PSD Logistic: Meszaging

IF P50 Logistics Interfacing

I PSD Logistics Signalling

I PSD Logistics Signaling Dot Met
I P50 Logistics Translating

I PSD Logistics Svnchronizing

I PSD Logistics &rchiving

I P50 Logistics Monitoring

23/11/2022 03:56:38 AM

Select “File” -> “Login” and log into the PSD Logistics Manager using the admin
account. The default password is “admin”. A number of menu items and features will
be displayed.




B3 PSD Logistics Manager 14.10.7

File

Settings

Admin  Help

PSD Logistics Manager

Services

Client Review

PSD Logistics Services

Test
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I P50 Logistics &uchive Reporting
b PSD Logistics Messaging

I P50 Logistics Interfacing

I PSD Logistics Signaling

I PSD Logistics Signalling Dot Met
I P50 Logistics Translating

P PSD Lagistics Synchronizing

I P50 Logistics Archiving

I PSD Logistics Monitaring

2311172022 10:02:24 &M
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Select “Admin” -> “Database” ->

“Backup To Zip”, and create a new backup file.

Make a note of the filename and folder of the backup file.
Filename :

Folder

Select the “Review” tab sheet and wait until all files are backed up. At the completion
of the backup, it will display “Backup to Zip Succeeded”.

File

Settings

Admin  Help

PSD Logistics Manager

Services

Client Review

Test

23M11/2022 10:04:57 AM Backing Up File ''TimeSheetsD ata 03"
| | 2%"1 1 x’gggg :Ig 94?3 AM Backing Up Databasze... Finished.

Information

Backup To Zip complete.

Please check the backup files before performing an upgrade.

121"

S TF L, [RENEL s [t L)
23A11/202210:04:58 AM
23M11/2022 10:04:58 Ak Backup to Zip - Stage 3 of 4 Succeeded.
2341142022 10:04:58 AM

2341142022 10:04:58
23/11/2022 10:04:58 AM Creating Backup File "C:\work\U pgrade20221123_04 2P
23/11/2022 10:04:58 AM Backing Up Database. .. Started.

2341142022 10:04:58 AM Backing Up File "'Photoz. DAT".

2341142022 10:04:58 AM Backing Up File "'Photoz.1Dx".

2311172022 10:04:58 AM Backing Up File "Photos. BLE".

23A11/2022 10:04:59 &M Backing Up Database. .. Finished,

2341142022 10:04:59 AM
2341142022 10:04:59 AM
23M11/2022 10:04:59 AM Backup to Zip - Stage 4 of 4 Succeeded.
2311720221 A

2341142022 10:05:02 AM

Check to make sure an error has not been recorded during the backup such as :
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“WARNING : THE DATABASE BACKUP FILE COUNT MAY BE INCORRECT.
PLEASE CHECK THE BACKUP FILE. [500 / 501]” This message can be raised if
there is insufficient disc space to add all files into the backup file.

File Settings Admin Help

PSD Logistics Manager
Services Client
L 23/11/2022 10, 20:08 AM Backing Up File

Information

Review Test

"WebServices. DAT™ L

X

WARNMING : THE DATABASE BACKUP FILE COUNT MAY BE INCORRECT. PLEASE CHECK THE BACKUP FILE. [963 /

964]

T T ST LT T
23/11/202210:20:07 &M Backing Up File
23/11/202210:20:07 &M B acking Up File
23/11/202210:20:07 &M B acking Up File
23/11/202210:20:07 &M B acking Up File
231172022 10:20:07 &M B acking Up File
2341172022 10:20:07 &M Backing Up File
2341172022 10:20:07 &M B acking Up File
2341172022 10:20:07 &M B acking Up File
23A11/202210:20:07 &M Backing Up File
234172022 10:20:07 &M Backing Up File
234172022 10:20:07 &M Backing Up File
231142022 10:20:07 AM

v ypG LT
“WorkforceMobilizationdccess Types. DX
“WorkforceMobilisations. DAT".

wiorkforcet obilisations. D",

workforcet obilisationsCurrent DAT "

" orkforce obilisationsCurrent. D",

"workforceM obilizationsS ettings. DAT "
"warkforceMobilizationsS ettings. 1 D=".

"WorkS chedulePatterns. DAT"

""wWorkS cheduleP atterns. D6,

"wWorkSchedules. DAT".

"wWorkSchedules. 10"

Deleting File C:%Pragram Files [#86/MPSDLogisticshServersD atabaze\ReaistivBack

23M1/202210:20:07 AM Backing Up D atabase... Finished.

231172022 10:20:07 AM
23/11/202210:20:07 AM

CKLUP FILE COUNT MaY BE INCORRECT. PLEAS

Z3A1/2022 10:26:38 AM

8 Select the “Services” tab sheet and click the “Stop All” button. Wait until all services
are stopped.
9 Select “Admin” -> “Services” -> “Disable All Services” to prevent services from

running again on this server.

10

Select “File” -> “Exit”.
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Stage 3 : Installing PSD Logistics on the new server

Step Action

1 Run the installation file (Install_PSD_Logistics.exe) and follow the prompts.

% P5D Legistics Installation

Welcome!

Thiz ingtallation program will install PSD Logistics.
Prezs the Mest button to start the installation. v'ou can press

the Cancel button fiow if you do not want to install PSD
Logigtics at thiz time.

IMPORTANT

[f inztalling ower an existing verzion, please log into the PSD
Logigtics Server and backup the database before proceeding.

Please ensure you hawve Administrataor rights before installing
PSD Logistics.

Cancel

1) Click “Next”.

2) Select “I Accept the terms in the Licence Agreement” then click “Next”.
3) Enter your Name and Company if blank then click “Next”.

4) Select the default location then click “Next”.

5) Select “Client” and “Server” then click “Next”.

6) Click “Next” then wait while the software is installed.

7) Click “Finished”.

If any PSD Logistics services or applications are still running on the server, the
installation will pause and ask you to stop the services or applications first.

If so, end the install and run the PSD Logistics Manager using “Run As
Administrator”. Log into the PSD Logistics Manager and click the “Stop All Services”
button. This application is located in the C:\Program Files
(x86)\PSDLogistics\Manager\ folder by default.

If the still running application is a PSD Logistics Client, you may need to run MS
Windows Task Manager and end task PSDLogisticsClient (e.g. if another operator is
running the client in another MS Windows session.

If all else fails, run MS Windows Task Manager and End Task all processes starting
with PSDLogistics.
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Stage 4 : Restoring the backup file into the new version.

Step

Action

1

Run PSDLogisticsManager.exe using “Run As Administrator”.
This application is located in the C:\Program Files (x86)\PSDLogistics\Manager\
folder by default.

B PSD Logistics Manager 14.10.7
File Help
PSD Logistice Manager

Services Client Review Test

PSD Logistics Services

I PSD Logistics Server

DE i

I P50 Logistics Cloud Server

I PSD Logistics Web Server

I PSD Logistics 'Webh Services

I P50 Logistics Reporting

I PSD Logistics &rchive Feparting
I PSD Logistics Meszaging

I PSD Logistics Interfacing

I PSD Logistics Signalling

D0BED0DE S

P PSD Lagistics Signalling Dat Met
I P50 Logistics Translating

I PSD Logistics Svnchronizing

I P50 Logistics Archiving

HEEDE

I PSD Logistics Monitaring

23/11/2022 03:56:38 AM

Select “File” -> “Login” and log into the PSD Logistics Manager using the admin
account. The default password is “admin”. A number of menu items and features will
be displayed.

B3 PSD Logistics Manager 14.10.7
File Settings Admin Help

PSD Logistics Manager

Services Client Review Test

v

ElEEEEEE =]
) ) () ) ) ) ) o) ) )
uEuElE e

PSD Logistics Services Start Al @ Stop Al

Start @ Stop
Start @ Stop
Start @ Stop

I P50 Logistics Server

DE| 1

b PSD Logistics Cloud Server

I PSD Logistics 'weh Server

I P50 Logistics Web Services Start @ Stop
I PSD Logistics Feporting Start @ Stop
Start @ Stop
Start @ Stop
Start @ Stop
Start @ Stop

Start @ Stop

I P50 Logistics &uchive Reporting
b PSD Logistics Messaging

I P50 Logistics Interfacing

I PSD Logistics Signaling

I PSD Logistics Signalling Dot Met
Start @ Stop
Start @ Stop
Start @ Stop
Start @ Stop

I P50 Logistics Translating
P PSD Lagistics Synchronizing
I P50 Logistics Archiving

LAl 4R dRb AR 4R 40 dNbdRhdRbhdRbhdlbhdRbhdlbhd

=
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E

I PSD Logistics Monitaring

2311172022 10:02:24 &M
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Select “Admin” -> “Database” -> “Restore From Zip” and browse to the file created in
Stage 1.

Wait until the backup file has been restored.

If this is not a major version upgrade, proceed to the next Step.

If this is a major version upgrade, select “Settings” -> “Registration” then contact
PSD for a new unlock code. Enter the new unlock code then select “Save” and
“Close”.

In the PSD Logistics Manager, click the PSD Logistics Server “Start” button and wait
until the server is marked as “Started”.

In the PSD Logistics Manager, select “File” -> “Exit”.
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Stage 5 : Updating any hostnames or IP addresses if required.

Step

Action

1

If the new server is assigned the same hostname and IP address of the old server,
then everything should work and this set can be ignored. Otherwise, perform these
steps to update any hostname and IP addresses.

Run PSDLogisticsManager.exe using “Run As Administrator”.
This application is located in the C:\Program Files (x86)\PSDLogistics\Manager\
folder by default.

5 PSD Legistics Manager 14.10.7
File Help

P5SD Logistics Manager

Services Client Review Test

E PSD Logistics Services

P PSD Logistics Server

E P PSD Logistics Cloud Server

I PSD Logistics Web Server

I PSD Logistics 'Web Services

I P50 Logistics Reparting

I PSD Logistics Archive Feporting
I PSD Logistics Messaging

I PSD Logistics Interfacing

P PSD Logistics Signaling

0 o 5 e

I PSD Logistics Signaling Dot Met
I PSD Logistics Translating

I PSD Logistics Synchronising

P PSD Logistics Archiving

I PSD Logistics Monitoring

EE T

23/11/2022 019:56:38 AM

Select “File” -> “Login” and log into the PSD Logistics Manager using the admin
account. The default password is “admin”. A number of menu items and features will
be displayed.

B PSD Logistics Manager 14.10.7
File Settings Admin Help
P5SD Logistics Manager

Services Client Review Test

E PSD Logistics Services
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Start Al @ Stop Al

I PSD Logistics Server
E P PSD Logistics Cloud Server
P PSD Logistics Web Server

Start @ Stop
Start & Stop
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I P50 Logistics Web Services Start @ Stop

I PSD Logistics Reparting Start @ Stop
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El

I P50 Logistics Archive Reporting Start & Stop

I PSD Logistics Messaging Start @ Stop
I PSD Logistics Interfacing Start @ Stop

I PSD Logistics Signalling Start @ Stop

EEED
RIEEIE

I PSD Logistics Signaling Dot Met Start @ Stop

O
[l

I P50 Logistics Translating Start @ Stop

B PSD Logistics Synchonizing Start & Stop

I PSD Logistics &rchiving Start & Stop

(W | (]| (T ||| (][]

=
=
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E

I PSD Logistics Monitoring Start @ Stop

23/11/2022 10:02:24 AM
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Select “Settings” -> “Access Management Software”

following access control systems:
1) Gallagher/Cardax.
Update the Gallagher/Cardax server details if required.

Access Management Software Settings

B« @

Acceszs Management Software

Software Mame GallagherCardax -

Main SAL Server APls DCOM Card Access Events Mizc

Gallagher Server

Depending upon your access control system, and depending upon whether or not
the access control system has been moved onto the new server as well, the
following settings may need to be updated. PSD Logistics is compatible with the

{®) Host Mame PSD-MEILAPCA | LocalHost | |

Ping

() |P Address
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Update the Gallagher/Cardax SQL Server server details if required.

Access Management Software

Saftware Mame |GallagherhEarda:¢ - |

Main :| SOL Server \kAPIs\k DCOM \kEard Access Events \kHisc

SOQL Server for Gallagher Database
Server Mame |F'SD-NEIL.-’-'«F'E4\G allagher

[ Defaut | | Test

EEE

|
Login Mame |psd1 23 |
|

Pazzword

‘windows Authentication
Guery People At | 12230 AM |
Query POFs

Update the Gallagher/Cardax folder paths if required. (e.g. The path may or
may not contain (x86).

Access Management Software Settings

B *&

Accessz Management Software

Software Mame |Gallagher'~.Earda:-: - |

Main \RSIJL Server \kAPIs\[ DCOM \kl:an:l Access Events \kHisc
DCOM XML Import Settings

Login Mame |F'SDLDgisticsIm|:nDlt |

SS————— |

Pazzword

Murmn Attemnpts 10 5

Irmport Timeout M0 5T | Minues
Maw Svnc Delay Minutes
Seszion Reset [w] Mirutes

Session Feset On Fai Usze Pricrity Queue

Cardholders Schema [on server] |E:\F'ru:ugram Filez [#BE]4G allagher\Commar «- |
Errors Folder |E:'~.F'n:ngram Files [«BENPSDLogiztice Sery -- |

Cloze ‘ | Help
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2) Lenel OnGuard
Update the Lenel OnGuard Server details if required.

Access Management Software Settings

B @

Acceszs Management Software

Software Mame |Lene| OnGuard - |

Main \k Open Access \k Signalling \k Card Accezs Events \k Mizc

Lenel OnGuard Server
(=) Host Name |PSD-NEILAPCY || LocalHost | |

) IP Address | | | | | |

3) PSD AcceptNet.
Update the PSD AcceptNet Server details if required.

Access Management Software Settings

B @
Access Management 5oftware

Saftware Name |F'SD Accepthet - |

Main \kF‘anels \I\Eard Access Events \l\lmpurt \I\Misc

P5SD AcceptMet Server
(& Hast Mame PSD-NEILAPCA | [ LocalHast_|

O IP address | | | | | | |
CCTY Port | 10001 3 |

[uemn People At | 1230 40 - |
[uery Extraz
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Update the PSD AcceptNet Query Directory if required. (e.g. The path may
or may not contain (x86).

Access Management Software Settings

3~ *&

Access Management 5oftware

Software Mame |F'SD AcceptMet - |

Main :| Panels \kEald Access Events \I\Impurl \Misc
Query Directary |E:\F'n:ngram Files [x8E\PS DLogisticssT ranslatic |

PSD AcceptNet Panels

Send Immed.

M ain Parel

&dd Panel || ModiyParel || Remove Panel |

Update the PSD AcceptNet Files and Directories if required. e.g. The path
may or may not contain (x86).

Access Management Software Settings

B« +®

Access Management Software

Software Mame |F'SD AcceptMet - |

Main \Panels \{ Card Access Events \I\Impurl \Hisc

PSD AcceptHet Review
Review Filz |E:\F‘rogram Filez [#BE]AcptS ervert AW TEMT.CLG

Default

Archive Directorny |E:\Program Files [«BE]\AcptServeribrchived Reviews Diefault

Granted Exit | Granted Access Out Drefault

Diefault

Denied Entry |Denied AccezsIn

[Granted Entry |Granted Accesz ln | Diefault
|
|
|

Denied Exit |Denied Access Out Diefault

Query Card Access Events

) Mever
(*) Once an Hour

() Once a Day at

Save and Close.
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Select “Settings” -> “Server”. Update the PSD Logistics server details if required.

Server Settings
3 &

Server Settings

Server \k Encryption

P5SD Logistics Server
(&) Hast Mame PSD-NEILAPCA [ LocalHost | [ Ping

O IP Address | | | | | |

Client Server Part | 150 :l

Save and Close.

Select “Settings” -> “Database”. Update the PSD Logistics directory details if
required. e.g. The paths may or may not contain (x86).

Database Settings

B« &

Database

Database \I\Backup \Hesture \Data Snapshot

Databaze Directorny | C:%Program Files [«BE]\PSDLogisticshServerD atabaze',

Temp D atabaze Directary |I::\F'r|:|gram Files [«B6]\PSDLogisticshServeriD atabaze\Temph

Database Port | 12007 5 |
Databaze Admin Part | 12008 : |

Lock Protocol
{(®) Optimiztic
) Pessimistic

Save and Close.
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Select “Settings” -> “E-Mail Settings”. Update the PSD Logistics SMTP details if
required.
Click the Test button to determine if the settings have been configured correctly.

E-rnail Settings

B +*&

E -mail

SMTP Client | Advanced . Notifications

Server |Smtp.gmail.cnm | |

Port 587 S

From | neillai@pzdlogistics. com |

Ilzername | neillai@pzdlogistics. com |

HERKEXNRRERR

Paszword

Save and Close.

Select “Settings” -> “SMS Settings”. Update the PSD Logistics SMS details if
required.
Click the Test button to determine if the settings have been configured correctly.

5MS Settings
B *@

SM5 Provider

Dlamain |messagenet.cnm.au

Prefis 'fith Country Code [ I:I
Set Message Length []

Set Subject ta Blank []

Save and Close.
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10 Select “Settings” -> “SNMP Settings”. Update the PSD Logistics SNMP details if
required.
Click the Test button to determine if the settings have been configured correctly.
SMMP Settings
Bv i+@
SHMP Settings
Trap ‘L Events
Host |PSD-NEILAPCY
Port 161 %
Trap Part 162 :
Community | public | D efault
Enterprize OID |1.3.E.1.4.1.453T2.1 | | Defaut | [ Test |
Cloge | | Help
Save and Close.
11 Log into every PSD Logistics Client, but do NOT log in. The login details window will

be displayed.

Enter your Login details.

Login Hame |

Paszword |

k. || Cancel ||

Click the server button and the PSD Logistics Server’s hostname or IP address will
be displayed.
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Update the PSD Logistics server details if required.

Connecting To The Server

Server Details

Server Not Found

Primary Server \kSecnndary Server

Server

(& HostName | PSD-NEILAPCY
O IP Address | || | |

|| Local Host ||

Ports

Server Port 2160 5
Database Poit 12007




